免费下载

IP-adapter合集模型工具:https://pan.quark.cn/s/241f5403923a

我们在ComfyUI使用IP-adapter-FaceID的时候,难免会报以下错误:

Error occurred when executing IPAdapterApply:
InsightFace must be provided for FaceID models.

File "F:\ComfyUI-aki\ComfyUI-aki-vl.3\execution.py", line 15l, inrecursive executeoutput_data, 
output ui = get output data(obj, input data al1)
File "F:\ComfyUI-aki\ComfyUI-aki-vl.3\execution.py", 
line 8l, in get_output_datareturn values = map node over list(obj, input data all, obj.FUNCTION,
allow interrupt=True)
File "F:\ComfyUI-aki\ComfyUI-aki-v1.3\execution.py", line 74, 
inmap node over listresults,append(getattr(obj, func)(**slice dict (input data al1, i)))
File "F:\ComfyUI-aki\ComfyUI-aki-v1.3\custom nodes\ComfyUI IPAdapter plus IPAdapterPlus. py", 
line 698,,inapply ipadapterraise Exception( InsightFace must be provided for FaceID models.’)

这个错误的原因是告诉我们,执行IPAdapterApply时发生错误,FaceID模型必须提供InsightFace;所以我们需要来安装InsightFace。

首先你需要来到comfyUI虚拟环境中,查看python版本,双击运行python.exe。

通过终端反馈,可以看见我的python版本是python3.11.6

接着再来下载对应版本的Insightface,比如我是python3.11.6,那我就下载insightface-0.7.3-cp311-cp311-win amd64.whl

(需要科学上网,没有的也可在页面中下载,我已经给你们打包好了。)

复制刚下载的Insightface文件地址(注意:路径不要有中文)

然后再回到comfyUI根目录,地址栏输入powershell或者cmd调出终端

输入以下命令,然后再贴上刚刚复制的Insightface文件地址回车(注意:地址需要有双引号格式,两端需要一个空格间隔,全程科学网络)

 .\python_embeded\python.exe -m pip install (这里是你的Insightface文件地址)onnxruntime

我这里已经安装过了,所以提示以存在

如果第一次安装,你会在终端收到以下提示:

Successfully installed cython-3.0.9 easvdict-1.13 insightface-0.7.3 onnx-1.15.0 prettvtable-3. 10. 0

最后再启动comfyUI,就能正常使用IP-adapter-faceID

加入Stable Diffusion交流群

(备注:SD)

声明:本站所有文章,如无特殊说明或标注,均为本站原创发布。任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。